ESXiとLinkAggregation-LAGの設定方法

構成

よくある構成としてL3スイッチでStackを組みその配下にサーバを設定してLANポートをLAGで束ねることがあると思います。 その時に必要なESXiの設定をします。

L3スイッチの設定

Stack構成なのでL3スイッチは2台ですがコンフィグは一つになります。LAGに必要なところのみ抜粋します。 trunk(dot1q)設定になっていますが、これはESXiでのタグVLANの使い方になりますので別記事で紹介します。 LAGを組むポートでポートチャネルを設定します。これでそれぞれのL3スイッチのポート7でLAGを組むことができます。

...
interface Port-channel7
 switchport trunk encapsulation dot1q
 switchport mode trunk
...
...
interface GigabitEthernet1/0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 7 mode on
!
...
...
interface GigabitEthernet2/0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 7 mode on
!
...

LAGには複数のプロトコルがありますが、LAGのmodeはon(スタティック)で設定します。 LACP,PAgPは使用しない(できない)からです。

LACPはvSphere5.1以降のvSphereDistributedSwitch(VDS)でのみ使用可能です、 参考:https://kb.vmware.com/s/article/2097845

LAGのプロトコル

PAgPはCisco独自のプロトコルのためCiscoのスイッチ間でのみ使用します。

ESXiの設定

仮想スイッチに設定を行います。仮想スイッチにはvmnicを2つ接続して先ほどL3スイッチでLAGを組んだポートと接続します。 仮想スイッチではチーミングの設定があり「IPハッシュに基づいたルート」に変更する必要があります。

これで設定完了です。 LAGを組む時は常に対向の設定を意識する必要がありますので注意しましょう。