Catalystの設定コンフィグ

初期設定時にやること

コンソール接続とtelnet時、enable時のパスワードは必ず設定します。 設定をしないとリモートからtelnetすることができません。

ホスト名の変更

Switch>;en
Switch#conf t
Switch(config)#
Switch(config)#hostname CoreL3SW01
CoreL3SW01(config)#

コンソール接続時のパスワード設定

Switch(config)# line console 0
Switch(config-line)# password `パスワード`
Switch(config-line)# login
Switch(config-line)# exit
Switch(config)#

telnet時のパスワード設定

Switch(config)# line vty 0 4
Switch(config-line)# password `パスワード`
Switch(config-line)# login
Switch(config-line)# exit
Switch(config)#

enableモード変更時のパスワード設定

Switch(config)# enable secret `パスワード`

コマンド打ち間違い時に時間がかかるのを防止

Switch(config)# no ip domain-lookup

設定の保存

Switch# write memory

VLAN

ネイティブVLANの設定

Switch(config)# interface VLAN 999
ip address 192.168.0.3 255.255.255.0

VLANの設定

Switch(config)# vlan 999
Switch(config-vlan)# name Manage-VLAN

インターフェースの設定

インターフェースの指定・有効化

Switch(config)# interface GigabitEthernet1/0/1
Switch(config)# interface VLAN
Switch(config)# interface range gigabitethernet1/0/1-4
Switch(config)# interface range gigabitEthernet1/0/1,gigabitEthernet1/0/4
Switch(config)# no shutdown

Trunkの設定

Switch(config)# switchport trunk encapsulation isl
Switch(config)# switchport mode trunk

  dot1q      Interface uses only 802.1q trunking encapsulation when trunking
  isl        Interface uses only ISL trunking encapsulation when trunking
  negotiate  Device will negotiate trunking encapsulation with peer on
             interface

LAGの設定

Switch(config)# interface Port-channel1
Switch(config)# switchport trunk encapsulation isl
Switch(config)# switchport mode trunk
Switch(config)# interface range gigabitEthernet1/0/1,gigabitEthernet1/0/2
Switch(config)# channel-group 1 mode active

active

LACPで動作。対向機器がLACPに対応している場合、activeで設定

on

対向がサーバなどでLACPに対応していない場合にonで設定